Ale.js

Install

Compatibility

Ale does not support IE8 and below because Ale uses ECMAScript 5 features that IE8 cannot simulate. But it supports all ECMAScript 5 compliant browsers.

Update log

Latest stable version: 1.2.0

See the GitHub for the update log for each version.

Directly introduced with <script>

Directly downloaded and introduced with the <script> tag, Ale will be registered as a global variable.

Do not use uncompressed ale.js files in production versions, otherwise this will slow down your file loading!


CDN

We recommend linking to a specific version number that you can manually update:

1
<script src="https://cdn.jsdelivr.net/npm/alejs@1.2.0/ale.js"></script>

Please confirm to understand the different builds and use the production environment version in your published site, replacing ale.js with ale.min.js.

NPM

NPM installation is recommended when building large applications with Ale, because NPM works well with module wrappers such as webpack or browserify.

1
2
# Latest stable version
$ npm i alejs

Found some errors? Edit on Github!